Resource Exhaustion Affecting python-eventlet package, versions <0.26.1-7


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.79% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-PYTHONEVENTLET-11765341
  • published10 Aug 2025
  • disclosed7 May 2021

Introduced: 7 May 2021

CVE-2021-21419  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade Debian:14 python-eventlet to version 0.26.1-7 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python-eventlet package and not the python-eventlet package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

Eventlet is a concurrent networking library for Python. A websocket peer may exhaust memory on Eventlet side by sending very large websocket frames. Malicious peer may exhaust memory on Eventlet side by sending highly compressed data frame. A patch in version 0.31.0 restricts websocket frame to reasonable limits. As a workaround, restricting memory usage via OS limits would help against overall machine exhaustion, but there is no workaround to protect Eventlet process.

CVSS Base Scores

version 3.1