Cross-site Scripting (XSS) Affecting python-markdown2 package, versions <2.3.9-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.93% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-PYTHONMARKDOWN2-11765435
  • published10 Aug 2025
  • disclosed20 Apr 2020

Introduced: 20 Apr 2020

CVE-2020-11888  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Debian:14 python-markdown2 to version 2.3.9-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python-markdown2 package and not the python-markdown2 package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

python-markdown2 through 2.3.8 allows XSS because element names are mishandled unless a \w+ match succeeds. For example, an attack might use elementname@ or elementname- with an onclick attribute.

CVSS Base Scores

version 3.1