Improper Input Validation Affecting raptor2 package, versions <2.0.14-1.2


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.14% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-RAPTOR2-11766808
  • published10 Aug 2025
  • disclosed13 May 2021

Introduced: 13 May 2021

CVE-2020-25713  (opens in a new tab)
CWE-20  (opens in a new tab)
CWE-125  (opens in a new tab)
CWE-122  (opens in a new tab)

How to fix?

Upgrade Debian:14 raptor2 to version 2.0.14-1.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream raptor2 package and not the raptor2 package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

A malformed input file can lead to a segfault due to an out of bounds array access in raptor_xml_writer_start_element_common.

CVSS Base Scores

version 3.1