Resource Exhaustion Affecting ruby-commonmarker package, versions <0.23.10-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.04% (61st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-RUBYCOMMONMARKER-11766831
  • published10 Aug 2025
  • disclosed31 Mar 2023

Introduced: 31 Mar 2023

CVE-2023-24824  (opens in a new tab)
CWE-400  (opens in a new tab)
CWE-407  (opens in a new tab)

How to fix?

Upgrade Debian:14 ruby-commonmarker to version 0.23.10-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-commonmarker package and not the ruby-commonmarker package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

cmark-gfm is GitHub's fork of cmark, a CommonMark parsing and rendering library and program in C. A polynomial time complexity issue in cmark-gfm may lead to unbounded resource exhaustion and subsequent denial of service. This CVE covers quadratic complexity issues when parsing text which leads with either large numbers of &gt; or - characters. This issue has been addressed in version 0.29.0.gfm.10. Users are advised to upgrade. Users unable to upgrade should validate that their input comes from trusted sources.

CVSS Base Scores

version 3.1