Improper Input Validation Affecting ruby-json package, versions <1.7.3-3


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
13.91% (97th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-RUBYJSON-11767150
  • published10 Aug 2025
  • disclosed13 Feb 2013

Introduced: 13 Feb 2013

CVE-2013-0269  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:14 ruby-json to version 1.7.3-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-json package and not the ruby-json package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

The JSON gem before 1.5.5, 1.6.x before 1.6.8, and 1.7.x before 1.7.7 for Ruby allows remote attackers to cause a denial of service (resource consumption) or bypass the mass assignment protection mechanism via a crafted JSON document that triggers the creation of arbitrary Ruby symbols or certain internal objects, as demonstrated by conducting a SQL injection attack against Ruby on Rails, aka "Unsafe Object Creation Vulnerability."

References

CVSS Base Scores

version 3.1