Directory Traversal Affecting ruby-rack package, versions <2.1.1-5


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.36% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-RUBYRACK-11767356
  • published10 Aug 2025
  • disclosed2 Jul 2020

Introduced: 2 Jul 2020

CVE-2020-8161  (opens in a new tab)
CWE-22  (opens in a new tab)
CWE-548  (opens in a new tab)

How to fix?

Upgrade Debian:14 ruby-rack to version 2.1.1-5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-rack package and not the ruby-rack package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

A directory traversal vulnerability exists in rack < 2.2.0 that allows an attacker perform directory traversal vulnerability in the Rack::Directory app that is bundled with Rack which could result in information disclosure.

CVSS Base Scores

version 3.1