CVE-2026-5223 Affecting rust-cargo package, versions <0.91.0-3


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.29% (21st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-RUSTCARGO-17090531
  • published29 May 2026
  • disclosed25 May 2026

Introduced: 25 May 2026

CVE-2026-5223  (opens in a new tab)

How to fix?

Upgrade Debian:14 rust-cargo to version 0.91.0-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rust-cargo package and not the rust-cargo package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

Cargo incorrectly handled symlinks inside of crate tarballs downloaded from third-party registries, allowing a malicious crate to override the source code of another crate from the same registry. The severity of the vulnerability is medium for users of third-party registries. Users of crates.io are not affected, as crates.io forbids uploading crates containing any symlink.

CVSS Base Scores

version 3.1