Resource Exhaustion Affecting rust-image package, versions <0.23.14-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.39% (31st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-RUSTIMAGE-11767588
  • published10 Aug 2025
  • disclosed31 Dec 2020

Introduced: 31 Dec 2020

CVE-2020-35916  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade Debian:14 rust-image to version 0.23.14-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rust-image package and not the rust-image package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

An issue was discovered in the image crate before 0.23.12 for Rust. A Mutable reference has immutable provenance. (In the case of LLVM, the IR may be always correct.)

CVSS Base Scores

version 3.1