Race Condition Affecting rust-lock-api package, versions <0.4.5-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.21% (11th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-RUSTLOCKAPI-11767435
  • published10 Aug 2025
  • disclosed31 Dec 2020

Introduced: 31 Dec 2020

CVE-2020-35914  (opens in a new tab)
CWE-362  (opens in a new tab)

How to fix?

Upgrade Debian:14 rust-lock-api to version 0.4.5-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rust-lock-api package and not the rust-lock-api package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

An issue was discovered in the lock_api crate before 0.4.2 for Rust. A data race can occur because of RwLockWriteGuard unsoundness.

CVSS Base Scores

version 3.1