Out-of-Bounds Affecting sdl-image1.2 package, versions <1.2.12-8


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.35% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-SDLIMAGE12-11767525
  • published10 Aug 2025
  • disclosed24 Apr 2018

Introduced: 24 Apr 2018

CVE-2017-14442  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:14 sdl-image1.2 to version 1.2.12-8 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream sdl-image1.2 package and not the sdl-image1.2 package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

An exploitable code execution vulnerability exists in the BMP image rendering functionality of SDL2_image-2.0.2. A specially crafted BMP image can cause a stack overflow resulting in code execution. An attacker can display a specially crafted image to trigger this vulnerability.

CVSS Base Scores

version 3.1