Cross-site Scripting (XSS) Affecting smarty4 package, versions <4.2.1-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.1% (65th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-SMARTY4-11767825
  • published10 Aug 2025
  • disclosed15 Sept 2022

Introduced: 15 Sep 2022

CVE-2018-25047  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Debian:14 smarty4 to version 4.2.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream smarty4 package and not the smarty4 package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

In Smarty before 3.1.47 and 4.x before 4.2.1, libs/plugins/function.mailto.php allows XSS. A web page that uses smarty_function_mailto, and that could be parameterized using GET or POST input parameters, could allow injection of JavaScript code by a user.

CVSS Base Scores

version 3.1