Arbitrary Code Injection Affecting smarty4 package, versions <4.1.1-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
4.91% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-SMARTY4-11767992
  • published10 Aug 2025
  • disclosed24 May 2022

Introduced: 24 May 2022

CVE-2022-29221  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade Debian:14 smarty4 to version 4.1.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream smarty4 package and not the smarty4 package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.45 and 4.1.1, template authors could inject php code by choosing a malicious {block} name or {include} file name. Sites that cannot fully trust template authors should upgrade to versions 3.1.45 or 4.1.1 to receive a patch for this issue. There are currently no known workarounds.

CVSS Base Scores

version 3.1