Race Condition Affecting spice-vdagent package, versions <0.20.0-2


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.33% (27th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-SPICEVDAGENT-11768340
  • published10 Aug 2025
  • disclosed26 Nov 2020

Introduced: 26 Nov 2020

CVE-2020-25653  (opens in a new tab)
CWE-362  (opens in a new tab)

How to fix?

Upgrade Debian:14 spice-vdagent to version 0.20.0-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream spice-vdagent package and not the spice-vdagent package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

A race condition vulnerability was found in the way the spice-vdagentd daemon handled new client connections. This flaw may allow an unprivileged local guest user to become the active agent for spice-vdagentd, possibly resulting in a denial of service or information leakage from the host. The highest threat from this vulnerability is to data confidentiality as well as system availability. This flaw affects spice-vdagent versions 0.20 and prior.

CVSS Base Scores

version 3.1