Improper Input Validation Affecting subversion package, versions <1.10.6-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.42% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-SUBVERSION-11768832
  • published10 Aug 2025
  • disclosed26 Sept 2019

Introduced: 26 Sep 2019

CVE-2018-11782  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:14 subversion to version 1.10.6-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream subversion package and not the subversion package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

In Apache Subversion versions up to and including 1.9.10, 1.10.4, 1.12.0, Subversion's svnserve server process may exit when a well-formed read-only request produces a particular answer. This can lead to disruption for users of the server.

CVSS Base Scores

version 3.1