Resource Exhaustion Affecting teeworlds package, versions <0.7.5-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.03% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-TEEWORLDS-11769518
  • published10 Aug 2025
  • disclosed22 Apr 2020

Introduced: 22 Apr 2020

CVE-2020-12066  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade Debian:14 teeworlds to version 0.7.5-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream teeworlds package and not the teeworlds package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

CServer::SendMsg in engine/server/server.cpp in Teeworlds 0.7.x before 0.7.5 allows remote attackers to shut down the server.

CVSS Base Scores

version 3.1