Out-of-Bounds Affecting tigervnc package, versions <1.7.0-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.18% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-TIGERVNC-11770730
  • published10 Aug 2025
  • disclosed28 Feb 2017

Introduced: 28 Feb 2017

CVE-2016-10207  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:14 tigervnc to version 1.7.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tigervnc package and not the tigervnc package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

The Xvnc server in TigerVNC allows remote attackers to cause a denial of service (invalid memory access and crash) by terminating a TLS handshake early.