Improper Authentication Affecting unattended-upgrades package, versions <0.86.1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.44% (70th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-UNATTENDEDUPGRADES-11771244
  • published10 Aug 2025
  • disclosed1 Jul 2015

Introduced: 1 Jul 2015

CVE-2015-1330  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade Debian:14 unattended-upgrades to version 0.86.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream unattended-upgrades package and not the unattended-upgrades package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

unattended-upgrades before 0.86.1 does not properly authenticate packages when the (1) force-confold or (2) force-confnew dpkg options are enabled in the DPkg::Options::* apt configuration, which allows remote man-in-the-middle attackers to upload and execute arbitrary packages via unspecified vectors.

CVSS Base Scores

version 3.1