XML External Entity (XXE) Injection Affecting yaws package, versions <2.0.8+dfsg-1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.35% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-YAWS-11774947
  • published10 Aug 2025
  • disclosed9 Sept 2020

Introduced: 9 Sep 2020

CVE-2020-24379  (opens in a new tab)
CWE-611  (opens in a new tab)

How to fix?

Upgrade Debian:14 yaws to version 2.0.8+dfsg-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream yaws package and not the yaws package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

WebDAV implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to XXE injection.

CVSS Base Scores

version 3.1