Integer Overflow or Wraparound Affecting zchunk package, versions <1.3.2+ds1-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.28% (20th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-ZCHUNK-11774807
  • published10 Aug 2025
  • disclosed19 Oct 2023

Introduced: 19 Oct 2023

CVE-2023-46228  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Debian:14 zchunk to version 1.3.2+ds1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream zchunk package and not the zchunk package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

zchunk before 1.3.2 has multiple integer overflows via malformed zchunk files to lib/comp/comp.c, lib/comp/zstd/zstd.c, lib/dl/multipart.c, or lib/header.c.

CVSS Base Scores

version 3.1