Out-of-Bounds Affecting cgit package, versions <0.10.2.git2.0.1-3+deb8u1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.79% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-CGIT-275000
  • published20 Jan 2016
  • disclosed20 Jan 2016

Introduced: 20 Jan 2016

CVE-2016-1901  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:8 cgit to version 0.10.2.git2.0.1-3+deb8u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cgit package and not the cgit package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

Integer overflow in the authenticate_post function in CGit before 0.12 allows remote attackers to have unspecified impact via a large value in the Content-Length HTTP header, which triggers a buffer overflow.