Improper Input Validation Affecting cgminer package, versions <4.2.3-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.22% (65th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-CGMINER-338492
  • published23 Jul 2014
  • disclosed23 Jul 2014

Introduced: 23 Jul 2014

CVE-2014-4503  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:8 cgminer to version 4.2.3-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cgminer package and not the cgminer package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

The parse_notify function in util.c in sgminer before 4.2.2 and cgminer 3.3.0 through 4.0.1 allows man-in-the-middle attackers to cause a denial of service (application exit) via a crafted (1) bbversion, (2) prev_hash, (3) nbit, or (4) ntime parameter in a mining.notify action stratum message.

CVSS Base Scores

version 3.1