Access Restriction Bypass Affecting chef package, versions <0.10.10-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.57% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-CHEF-307506
  • published8 Aug 2012
  • disclosed8 Aug 2012

Introduced: 8 Aug 2012

CVE-2010-5142  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade Debian:8 chef to version 0.10.10-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream chef package and not the chef package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

chef-server-api/app/controllers/users.rb in the API in Chef before 0.9.0 does not require administrative privileges for the create, destroy, and update methods, which allows remote authenticated users to manage user accounts via requests to the /users URI.

CVSS Base Scores

version 3.1