Use of Insufficiently Random Values Affecting cloud-init package, versions <0.7.6~bzr976-2+deb8u1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.44% (36th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-CLOUDINIT-546654
  • published5 Feb 2020
  • disclosed5 Feb 2020

Introduced: 5 Feb 2020

CVE-2020-8631  (opens in a new tab)
CWE-330  (opens in a new tab)

How to fix?

Upgrade Debian:8 cloud-init to version 0.7.6~bzr976-2+deb8u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cloud-init package and not the cloud-init package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

cloud-init through 19.4 relies on Mersenne Twister for a random password, which makes it easier for attackers to predict passwords, because rand_str in cloudinit/util.py calls the random.choice function.

CVSS Base Scores

version 3.1