Directory Traversal Affecting deluge package, versions <1.3.10-3+deb8u1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.5% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-DELUGE-282380
  • published17 May 2017
  • disclosed17 May 2017

Introduced: 17 May 2017

CVE-2017-9031  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Debian:8 deluge to version 1.3.10-3+deb8u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream deluge package and not the deluge package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

The WebUI component in Deluge before 1.3.15 contains a directory traversal vulnerability involving a request in which the name of the render file is not associated with any template file.