Missing Authorization Affecting firebird2.5 package, versions <2.5.3.26778.ds4-5+deb8u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.3% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-FIREBIRD25-282392
  • published24 Mar 2017
  • disclosed24 Mar 2017

Introduced: 24 Mar 2017

CVE-2017-6369  (opens in a new tab)
CWE-862  (opens in a new tab)

How to fix?

Upgrade Debian:8 firebird2.5 to version 2.5.3.26778.ds4-5+deb8u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream firebird2.5 package and not the firebird2.5 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

Insufficient checks in the UDF subsystem in Firebird 2.5.x before 2.5.7 and 3.0.x before 3.0.2 allow remote authenticated users to execute code by using a 'system' entrypoint from fbudf.so.

CVSS Base Scores

version 3.1