SQL Injection Affecting firebird2.5 package, versions <2.5.3.26778.ds4-5+deb8u2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
6.15% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-FIREBIRD25-282395
  • published28 Mar 2018
  • disclosed28 Mar 2018

Introduced: 28 Mar 2018

CVE-2017-11509  (opens in a new tab)
CWE-89  (opens in a new tab)

How to fix?

Upgrade Debian:8 firebird2.5 to version 2.5.3.26778.ds4-5+deb8u2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream firebird2.5 package and not the firebird2.5 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

An authenticated remote attacker can execute arbitrary code in Firebird SQL Server versions 2.5.7 and 3.0.2 by executing a malformed SQL statement.

CVSS Base Scores

version 3.1