Resource Management Errors Affecting firebird2.5 package, versions <2.5.2~svn+54698.ds4-2


Severity

Recommended
0.0
low
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.84% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-FIREBIRD25-282398
  • published20 Nov 2012
  • disclosed20 Nov 2012

Introduced: 20 Nov 2012

CVE-2012-5529  (opens in a new tab)
CWE-399  (opens in a new tab)

How to fix?

Upgrade Debian:8 firebird2.5 to version 2.5.2~svn+54698.ds4-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream firebird2.5 package and not the firebird2.5 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

TraceManager in Firebird 2.5.0 and 2.5.1, when trace is enabled, allows remote authenticated users to cause a denial of service (NULL pointer dereference and crash) by preparing an empty dynamic SQL query.

CVSS Base Scores

version 3.1