Out-of-Bounds Affecting firebird2.5 package, versions <2.5.2~svn+54698.ds4-2


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
42.17% (99th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-FIREBIRD25-282401
  • published15 Mar 2013
  • disclosed15 Mar 2013

Introduced: 15 Mar 2013

CVE-2013-2492  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:8 firebird2.5 to version 2.5.2~svn+54698.ds4-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream firebird2.5 package and not the firebird2.5 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

Stack-based buffer overflow in Firebird 2.1.3 through 2.1.5 before 18514, and 2.5.1 through 2.5.3 before 26623, on Windows allows remote attackers to execute arbitrary code via a crafted packet to TCP port 3050, related to a missing size check during extraction of a group number from CNCT information.

CVSS Base Scores

version 3.1