Integer Overflow or Wraparound Affecting gcc-4.8 package, versions <4.8.3-7


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
5.57% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-GCC48-309208
  • published7 Mar 2018
  • disclosed7 Mar 2018

Introduced: 7 Mar 2018

CVE-2014-5044  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Debian:8 gcc-4.8 to version 4.8.3-7 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gcc-4.8 package and not the gcc-4.8 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

Multiple integer overflows in libgfortran might allow remote attackers to execute arbitrary code or cause a denial of service (Fortran application crash) via vectors related to array allocation.

CVSS Base Scores

version 3.1