Integer Overflow or Wraparound Affecting gcc-4.8 package, versions <4.8.0-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.55% (42nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-GCC48-309213
  • published27 Jun 2018
  • disclosed23 Oct 2019

Introduced: 27 Jun 2018

CVE-2002-2439  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Debian:8 gcc-4.8 to version 4.8.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gcc-4.8 package and not the gcc-4.8 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

Integer overflow in the new[] operator in gcc before 4.8.0 allows attackers to have unspecified impacts.

CVSS Base Scores

version 3.1