CVE-2005-1686 Affecting gedit package, versions <2.10.3-1


Severity

Recommended
0.0
low
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
7.66% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-GEDIT-288232
  • published20 May 2005
  • disclosed20 May 2005

Introduced: 20 May 2005

CVE-2005-1686  (opens in a new tab)

How to fix?

Upgrade Debian:8 gedit to version 2.10.3-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gedit package and not the gedit package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

Format string vulnerability in gedit 2.10.2 may allow attackers to cause a denial of service (application crash) via a bin file with format string specifiers in the filename. NOTE: while this issue is triggered on the command line by the gedit user, it has been reported that web browsers and email clients could be configured to provide a file name as an argument to gedit, so there is a valid attack that crosses security boundaries.

CVSS Base Scores

version 3.1