Inadequate Encryption Strength Affecting gnupg package, versions <1.4.1-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.95% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-GNUPG-340565
  • published2 May 2005
  • disclosed2 May 2005

Introduced: 2 May 2005

CVE-2005-0366  (opens in a new tab)
CWE-326  (opens in a new tab)

How to fix?

Upgrade Debian:8 gnupg to version 1.4.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gnupg package and not the gnupg package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

The integrity check feature in OpenPGP, when handling a message that was encrypted using cipher feedback (CFB) mode, allows remote attackers to recover part of the plaintext via a chosen-ciphertext attack when the first 2 bytes of a message block are known, and an oracle or other mechanism is available to determine whether an integrity check failed.

CVSS Base Scores

version 3.1