Out-of-Bounds Affecting gnuplot package, versions <4.6.6-2+deb8u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.78% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-GNUPLOT-279849
  • published2 Dec 2018
  • disclosed23 Nov 2018

Introduced: 23 Nov 2018

CVE-2018-19492  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:8 gnuplot to version 4.6.6-2+deb8u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gnuplot package and not the gnuplot package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

An issue was discovered in cairo.trm in Gnuplot 5.2.5. This issue allows an attacker to conduct a buffer overflow with an arbitrary amount of data in the cairotrm_options function. This flaw is caused by a missing size check of an argument passed to the "set font" function. This issue occurs when the Gnuplot pngcairo terminal is used as a backend.