Improper Initialization Affecting gst-plugins-bad0.10 package, versions <0.10.23-7.4+deb8u2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.6% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-GSTPLUGINSBAD010-386040
  • published23 Jan 2017
  • disclosed23 Jan 2017

Introduced: 23 Jan 2017

CVE-2016-9446  (opens in a new tab)
CWE-665  (opens in a new tab)

How to fix?

Upgrade Debian:8 gst-plugins-bad0.10 to version 0.10.23-7.4+deb8u2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gst-plugins-bad0.10 package and not the gst-plugins-bad0.10 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

The vmnc decoder in the gstreamer does not initialize the render canvas, which allows remote attackers to obtain sensitive information as demonstrated by thumbnailing a simple 1 frame vmnc movie that does not draw to the allocated render canvas.

CVSS Base Scores

version 3.1