Numeric Errors Affecting gst-plugins-bad0.10 package, versions <0.10.10.2-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.67% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-GSTPLUGINSBAD010-386048
  • published27 Apr 2009
  • disclosed27 Apr 2009

Introduced: 27 Apr 2009

CVE-2009-1438  (opens in a new tab)
CWE-189  (opens in a new tab)

How to fix?

Upgrade Debian:8 gst-plugins-bad0.10 to version 0.10.10.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gst-plugins-bad0.10 package and not the gst-plugins-bad0.10 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

Integer overflow in the CSoundFile::ReadMed function (src/load_med.cpp) in libmodplug before 0.8.6, as used in gstreamer-plugins, TTPlayer, and other products, allows context-dependent attackers to execute arbitrary code via a MED file with a crafted (1) song comment or (2) song name, which triggers a heap-based buffer overflow, as exploited in the wild in August 2008.

CVSS Base Scores

version 3.1