Out-of-bounds Read Affecting gst-plugins-bad1.0 package, versions <1.4.4-2.1+deb8u2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.43% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-GSTPLUGINSBAD10-399753
  • published9 Feb 2017
  • disclosed9 Feb 2017

Introduced: 9 Feb 2017

CVE-2017-5848  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Debian:8 gst-plugins-bad1.0 to version 1.4.4-2.1+deb8u2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gst-plugins-bad1.0 package and not the gst-plugins-bad1.0 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

The gst_ps_demux_parse_psm function in gst/mpegdemux/gstmpegdemux.c in gst-plugins-bad in GStreamer allows remote attackers to cause a denial of service (invalid memory read and crash) via vectors involving PSM parsing.

CVSS Base Scores

version 3.1