Improper Input Validation Affecting hplip package, versions <2.8.6-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.54% (42nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-HPLIP-300331
  • published14 Aug 2008
  • disclosed14 Aug 2008

Introduced: 14 Aug 2008

CVE-2008-2941  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:8 hplip to version 2.8.6-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream hplip package and not the hplip package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

The hpssd message parser in hpssd.py in HP Linux Imaging and Printing (HPLIP) 1.6.7 allows local users to cause a denial of service (process stop) via a crafted packet, as demonstrated by sending "msg=0" to TCP port 2207.

CVSS Base Scores

version 3.1