Out-of-Bounds Affecting libguac package, versions <0.6.0-2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
13.58% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-LIBGUAC-265500
  • published1 Oct 2012
  • disclosed1 Oct 2012

Introduced: 1 Oct 2012

CVE-2012-4415  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:8 libguac to version 0.6.0-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libguac package and not the libguac package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

Stack-based buffer overflow in the guac_client_plugin_open function in libguac in Guacamole before 0.6.3 allows remote attackers to cause a denial of service (crash) or execute arbitrary code via a long protocol name.

CVSS Base Scores

version 3.1