Information Exposure Affecting libsocialweb package, versions <0.25.20-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.8% (76th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-LIBSOCIALWEB-272593
  • published22 Oct 2012
  • disclosed22 Oct 2012

Introduced: 22 Oct 2012

CVE-2011-4129  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Debian:8 libsocialweb to version 0.25.20-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsocialweb package and not the libsocialweb package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

(1) services/twitter/twitter-contact-view.c and (2) services/twitter/twitter-item-view.c in libsocialweb before 0.25.20 automatically connect to Twitter when no Twitter account is set, which might allow remote attackers to obtain sensitive information via a man-in-the-middle (MITM) attack.

CVSS Base Scores

version 3.1