Numeric Errors Affecting libv8-3.14 package, versions *


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.2% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-LIBV8314-355926
  • published22 Jan 2015
  • disclosed22 Jan 2015

Introduced: 22 Jan 2015

CVE-2014-7927  (opens in a new tab)
CWE-189  (opens in a new tab)

How to fix?

There is no fixed version for Debian:8 libv8-3.14.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libv8-3.14 package and not the libv8-3.14 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

The SimplifiedLowering::DoLoadBuffer function in compiler/simplified-lowering.cc in Google V8, as used in Google Chrome before 40.0.2214.91, does not properly choose an integer data type, which allows remote attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact via crafted JavaScript code.

CVSS Base Scores

version 3.1