Improper Access Control Affecting libv8-3.14 package, versions *


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.76% (75th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-LIBV8314-355983
  • published12 Oct 2015
  • disclosed12 Oct 2015

Introduced: 12 Oct 2015

CVE-2015-1304  (opens in a new tab)
CWE-284  (opens in a new tab)

How to fix?

There is no fixed version for Debian:8 libv8-3.14.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libv8-3.14 package and not the libv8-3.14 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

object-observe.js in Google V8, as used in Google Chrome before 45.0.2454.101, does not properly restrict method calls on access-checked objects, which allows remote attackers to bypass the Same Origin Policy via a (1) observe or (2) getNotifier call.

CVSS Base Scores

version 3.1