Resource Exhaustion Affecting linux-4.9 package, versions <4.9.110-3+deb9u2~deb8u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
71.77% (100th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-LINUX49-263031
  • published6 Aug 2018
  • disclosed6 Aug 2018

Introduced: 6 Aug 2018

CVE-2018-5390  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade Debian:8 linux-4.9 to version 4.9.110-3+deb9u2~deb8u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream linux-4.9 package and not the linux-4.9 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

Linux kernel versions 4.9+ can be forced to make very expensive calls to tcp_collapse_ofo_queue() and tcp_prune_ofo_queue() for every incoming packet which can lead to a denial of service.

References

CVSS Base Scores

version 3.1