Improper Input Validation Affecting linux-4.9 package, versions *


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.02% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-LINUX49-263042
  • published9 Feb 2018
  • disclosed9 Feb 2018

Introduced: 9 Feb 2018

CVE-2018-1000026  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

There is no fixed version for Debian:8 linux-4.9.

NVD Description

Note: Versions mentioned in the description apply only to the upstream linux-4.9 package and not the linux-4.9 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

Linux Linux kernel version at least v4.8 onwards, probably well before contains a Insufficient input validation vulnerability in bnx2x network card driver that can result in DoS: Network card firmware assertion takes card off-line. This attack appear to be exploitable via An attacker on a must pass a very large, specially crafted packet to the bnx2x card. This can be done from an untrusted guest VM..

CVSS Base Scores

version 3.1