Use After Free Affecting linux-4.9 package, versions <4.9.110-3+deb9u5~deb8u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
3.21% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-LINUX49-263044
  • published25 Sept 2018
  • disclosed19 Sept 2018

Introduced: 19 Sep 2018

CVE-2018-17182  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Debian:8 linux-4.9 to version 4.9.110-3+deb9u5~deb8u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream linux-4.9 package and not the linux-4.9 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

An issue was discovered in the Linux kernel through 4.18.8. The vmacache_flush_all function in mm/vmacache.c mishandles sequence number overflows. An attacker can trigger a use-after-free (and possibly gain privileges) via certain thread creation, map, unmap, invalidation, and dereference operations.

CVSS Base Scores

version 3.1