Memory Leak Affecting linux-4.9 package, versions <4.9.168-1~deb8u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
5.92% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-LINUX49-345444
  • published21 Feb 2019
  • disclosed21 Feb 2019

Introduced: 21 Feb 2019

CVE-2019-8980  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade Debian:8 linux-4.9 to version 4.9.168-1~deb8u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream linux-4.9 package and not the linux-4.9 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

A memory leak in the kernel_read_file function in fs/exec.c in the Linux kernel through 4.20.11 allows attackers to cause a denial of service (memory consumption) by triggering vfs_read failures.

CVSS Base Scores

version 3.1