NULL Pointer Dereference Affecting linux-4.9 package, versions <4.9.168-1~deb8u1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
5.67% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-LINUX49-345484
  • published5 Mar 2019
  • disclosed5 Mar 2019

Introduced: 5 Mar 2019

CVE-2019-9213  (opens in a new tab)
CWE-476  (opens in a new tab)

How to fix?

Upgrade Debian:8 linux-4.9 to version 4.9.168-1~deb8u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream linux-4.9 package and not the linux-4.9 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

In the Linux kernel before 4.20.14, expand_downwards in mm/mmap.c lacks a check for the mmap minimum address, which makes it easier for attackers to exploit kernel NULL pointer dereferences on non-SMAP platforms. This is related to a capability check for the wrong task.

References

CVSS Base Scores

version 3.1