Memory Leak Affecting linux-4.9 package, versions <4.9.210-1~deb8u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
5.23% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-LINUX49-551810
  • published18 Nov 2019
  • disclosed18 Nov 2019

Introduced: 18 Nov 2019

CVE-2019-19052  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade Debian:8 linux-4.9 to version 4.9.210-1~deb8u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream linux-4.9 package and not the linux-4.9 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

A memory leak in the gs_can_open() function in drivers/net/can/usb/gs_usb.c in the Linux kernel before 5.3.11 allows attackers to cause a denial of service (memory consumption) by triggering usb_submit_urb() failures, aka CID-fb5be6a7b486.

CVSS Base Scores

version 3.1