Memory Leak Affecting linux-4.9 package, versions <4.9.210-1~deb8u1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.99% (58th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-LINUX49-551856
  • published30 Dec 2019
  • disclosed30 Dec 2019

Introduced: 30 Dec 2019

CVE-2019-20096  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade Debian:8 linux-4.9 to version 4.9.210-1~deb8u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream linux-4.9 package and not the linux-4.9 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

In the Linux kernel before 5.1, there is a memory leak in __feat_register_sp() in net/dccp/feat.c, which may cause denial of service, aka CID-1d3ff0950e2b.

CVSS Base Scores

version 3.1