Improper Input Validation Affecting lynx-cur package, versions <2.8.6-6


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.75% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-LYNXCUR-266874
  • published18 Oct 2004
  • disclosed18 Oct 2004

Introduced: 18 Oct 2004

CVE-2004-1617  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:8 lynx-cur to version 2.8.6-6 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lynx-cur package and not the lynx-cur package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

Lynx, lynx-ssl, and lynx-cur before 2.8.6dev.8 allow remote attackers to cause a denial of service (infinite loop) via a web page or HTML email that contains invalid HTML including (1) a TEXTAREA tag with a large COLS value and (2) a large tag name in an element that is not terminated, as demonstrated by mangleme. NOTE: a followup suggests that the relevant trigger for this issue is the large COLS value.

CVSS Base Scores

version 3.1