Out-of-Bounds Affecting lynx-cur package, versions <2.8.8dev.5-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.66% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-LYNXCUR-266878
  • published20 Aug 2010
  • disclosed20 Aug 2010

Introduced: 20 Aug 2010

CVE-2010-2810  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:8 lynx-cur to version 2.8.8dev.5-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lynx-cur package and not the lynx-cur package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

Heap-based buffer overflow in the convert_to_idna function in WWW/Library/Implementation/HTParse.c in Lynx 2.8.8dev.1 through 2.8.8dev.4 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a malformed URL containing a % (percent) character in the domain name.

CVSS Base Scores

version 3.1